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PersonalFolder Driver Installation – Windows Security Message
During PersonalFolder Setup, on the Windows Security Message screen you need to click

“Install this driver software anyway”

Ensure that you click the “Install this driver software anyway” option
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About

This software provides more data privacy without encryption to users generally for those having
computers which might be shared or used by others. The user can keep data in the PersonalFolder and
then lock it which makes it unavailable through Windows Explorer but if the password is forgotten and
no password recovery file has been created the data can still be read from the hard disk for which the
user might need professional assistance.
The issues of encryption key getting lost or encryption itself don't exist. This software just provides data
privacy and probably enough for most users at their personal level. Of course, for business work
encryption software have their values but the businesses have proper infrastructure to manage it.
-Username and Password
Each PersonalFolder is created with a username and a password. Upon login, the PersonalFolder
becomes available through Windows Explorer for reading and writing data to it. Upon logout, the
PersonalFolder data is not available through Windows Explorer but if you forget your password or
somehow lose your PersonalFolder User Key file which is stored outside of the PersonalFolder storage
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file and hence could be tampered with from outside of the PersonalFolder program then your data can
still be read from the hard disk but for which you might need professional assistance. The program
encrypts the first sector of your PersonalFolder storage file for not letting just any other software open it
and the encryption key is kept protected using your password.
A password recovery file can be created by the user either while creating the PersonalFolder or while
changing the password. This file lets the user recover and then even change the password by providing
the correct answers.
-Free Version
The Free Version of PersonalFolder software creates a FREE maximum of 50 MB storage per
PersonalFolder Username. Any number of usernames can be created on a machine. The FREE Version of
the software doesn't let users change password of a PersonalFolder larger than 50 MB size which
could've been imported into the FREE Version using the USB option.
-USB
A software option being implemented will let users of FREE or LICENSED Version export their
PersonalFolder related files to another storage location like an USB and will let users import those files
on any computer having even just the FREE Version of the software.
-Licensed Version
The Licensed version lets users create a maximum of 9999 MB storage per PersonalFolder Username. It
is recommended that you read the screens properly when using the program.
-Crypto Students/Professionals
The User key for the PersonalFolder storage is stored encrypted on the hard disk using publicly available
cryptographic libraries about which I would mention here. When a Password Recovery file option is
selected, the Password is stored encrypted on the hard disk too for making it recoverable. A few
versions of the software would vary just in use of the different publicly available cryptographic libraries.
In this regard, the infrastructure of this software could be used by crypto students/professionals for
their own efforts. When I've released a few versions using the different libraries then I should've
improved the software infrastructure for making others much easily integrate their efforts with this.
The program screens (Ex. Create New User, Log In) themselves provide information required for using
them. This document contains general information on using the software and its options.
Kindly read the steps for use and general options before using the software.
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Steps for use
Launching PersonalFolder software
A. Standard
1. Desktop -> PersonalFolder (Locked) icon
2. Start -> All Programs -> PersonalFolder -> PersonalFolder
B. Advanced Users
3. [PersonalFolder program folder]\PersonalFolder.exe
Ex. C:\Program Files\PersonalFolder\PersonalFolder.exe
4. Double-Click PersonalFolder file from
[PersonalFolder program folder]\PersFldrs\personalfolder_USERNAME.persfldr

Opening your PersonalFolder for keeping data
A. Create Username, Password, and Storage for your PersonalFolder
When you run the PersonalFolder software but no Username has been created, the program would
direct you to the Create New User screen. From Create New User screen, you have option for creating a
Password Recovery File, and help.
B. Log-In with Username and Password of created PersonalFolder
If a PersonalFolder Username exists whether created by you or someone else on your computer, the
program would direct you to the Log In screen. From Log In screen, you have options for creating a new
user, changing or recovering password, and help.

General Options
Log In screen
It has the following options:
Log In
Provide Username and Password of your PersonalFolder to open your PersonalFolder.
Forgot Password
Lets you change forgotten password for a Username using a related Password Recovery File (more info
under General Options -> Password Recovery File).
Change Password
Lets you change password for a Username.
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When you change your password, your earlier Password Recovery File if any gets deleted and you are
presented with the Password Recovery File creation screen which you can use to create another one. If
you don't create a Password Recovery File and you forget your password, you wouldn't be able to
recover it. Without your password, you wouldn't be able to open your PersonalFolder from the
software.
The data in your PersonalFolder is stored unencrypted so you should be able to recover it from your
hard disk for which you might need professional assistance.
Create New User
Lets you create Username, Password, and Storage for your PersonalFolder.
Help
Open this file.

Password Recovery File (OPTIONAL)
During Creation of your PersonalFolder or Changing your Password, you can select to create a Password
Recovery File by providing answers to some questions. The Password Recovery File keeps the user's
password encrypted using the answers.
If you click the Cancel button on the Password Recovery (OPTIONAL) screen, the program doesn't create
this file for your Username and your Password is not stored on the hard disk. If you create this file, you
can recover your Password if you provide the correct answers which you had provided while creating
this file.

Taskbar Icons and Menu
After launching the PersonalFolder software, your Taskbar will have the PersonalFolder Locked icon.
Until no PersonalFolder is open, the icon will be the PersonalFolder Locked icon. When you create a
new user or log in and your PersonalFolder opens, the icon will become the PersonalFolder Open icon.
Very Important: If your Taskbar is unresponsive, you might need to wait or restart your computer.

You can right-click the PersonalFolder Open icon for a menu.

Taskbar Icon, when PersonalFolder is Locked
Taskbar Icon, when PersonalFolder is Open
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PersonalFolder Taskbar Menu options
Lock & Exit
This Locks the open PersonalFolder when all the files and folders within the PersonalFolder are closed
and PersonalFolder is not open within any Windows Explorer windows.
On clicking this option, either you will get a message box mentioning that your PersonalFolder cannot be
locked due to given reasons or your PersonalFolder Taskbar icon will become the Locked icon. Then it
will display a message on your Taskbar for options to launch the PersonalFolder software again. Then it
will remain on the Taskbar for a short while during when you wouldn’t be able to launch the software
until it removes itself.
PersonalFolder Explorer
This Opens the PersonalFolder in a Windows Explorer window.
Help -> Manual
This opens this file.
Help -> Buy Now
Download 60 day trial from http://www.personalfoldersoftware.com
Help -> About PersonalFolder
This opens a screen with the copyright and other information.

PersonalFolder Storage File Icon and Menu

All PersonalFolder storage files have this icon
PersonalFolder Storage Menu
When you double-click on a PersonalFolder storage file, if no PersonalFolder is open then Log In screen
opens but if a PersonalFolder is open then it opens in a Windows Explorer window. So double-clicking on
a PersonalFolder storage file doesn’t open that particular PersonalFolder storage file.
This icon should help find PersonalFolder storage files which the user can backup from outside of the
PersonalFolder program by copying it to different storage media. Even if the user forgets the
PersonalFolder password, the data in the storage is unencrypted and hence can be recovered from the
hard disk for which the user might need professional assistance.
If the user backs up this file, the user should also backup the related User Key file and the Password
Recovery file. These files are kept in the program folder sub folders Key, and PRF respectively with
names USERNAME.user and USERNAME.prf respectively. Your PersonalFolder storage file could be in
the program sub folder PersFldrs or another location if you had browsed for it on the Creation screen
with name personalfolder_USERNAME.persfldr
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Restore from Backup (Manual Effort)
The PersonalFolder software doesn’t provide a feature to backup your PersonalFolder or restore your
backup. However, if you had to re-install the Windows OS which formatted the partition on which your
PersonalFolder program was installed or for any other reason your PersonalFolder program folder was
deleted or the containing files were deleted, you should be able to restore from your backup. In this
regard, I provide the following steps for which you might need professional assistance:
Ensure PersonalFolder program is installed. To get the installation path, launch the PersonalFolder
program once using icon on Desktop or another shortcut. If the program launches, the program
installation path can be got by right-clicking the icon -> Properties -> Target details.
Example of program folder installation path: C:\Program Files\PersonalFolder
Then save the backed up User, PRF (if existing), and PersonalFolder files in the respective sub folders of
the program folder as described in above section.
Example: C:\Program Files\PersonalFolder\Key\USERNAME.user (if USERNAME.user is backup filename)
Example: C:\Program Files\PersonalFolder\PRF\USERNAME.prf (if USERNAME.prf is backup filename)
Click Start -> Type “regedit” -> Click Enter
Registry Editor opens in which:
Click HKEY_LOCAL_MACHINE -> Click SOFTWARE -> Click PersonalFolder -> Click DefPersFldrs
In the panel on right-side,
Right-Click in the blank are -> Click New -> Click String Value
(An editable textbox with highlighted value “New Value #1” or similar will be created)
Change value in this textbox by typing in your USERNAME which can be got from your Key, PRF, or
PersonalFolder filename as described above.
Then Right-Click on your USERNAME -> Click Modify -> An Edit String form opens
In the Value data textbox, you need to enter the full path name of your PersonalFolder file.
Example: C:\Program Files\PersonalFolder\PersFldrs\personalfolder_username.persfldr
Now, you can login with this USERNAME given the related files haven’t been tampered with.
Even if there’s no backup feature, you should regularly backup the files mentioned above to a
removable media like any other data for if any part of your system crashes. You could have different
Usernames some for data which you backup and others for which you don’t. The PersonalFolder FREE
Version will restore your backup even if with limited functionality but you get to access your data.
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